[OpenAFS] Unable to Obtain Tokens

Jason C. Wells jcw@highperformance.net
Wed, 3 Dec 2003 22:42:42 -0800 (PST)

On Wed, 3 Dec 2003, Jeffrey Altman wrote:

> Another possibility is that you no longer have authorization to open the
> NT SC Manager or the AFS Client Service.
> You might want to try the 1.3.50 build, you can find an installer at
>   /afs/athena.mit.edu/user/j/a/jaltman/Public/OpenAFS/
> Be sure to uninstall the previous version first.  This installer uses
> the NSIS installer instead of InstallShield.  I am not sure it can
> update an InstallShield installation of OpenAFS.

This worked.  Everything was running fine.

Then it wasn't.  This time I knew that I had only changed the global drive
mappings.  I also elected not to preserve my config files.  This proved to
be important as you might discern from the rest of this message.

During this most recent iteration, I had tried to change my global drive
mappings to z: and h:.  The trouble started after trying to change the
drive mappings.  When trying to change the drive mappings, I would get
some error saying "Description Already Used".

I then tried manually editing the afsdsbmt.ini file to delete the "already
described" mappings so that I could then use the afs_config dialog to set
up my mappings the way I wanted.  This didn't help.

I have restored my afsdsbmt.ini and voila, AFS client is back to working.
But not with the drive mappings I desire.

While I was doing all of this, I noticed that what afsdsbmt.ini lists as
drive mappings and what windows lists as drive mappings are two different
things.  This was strange.

While trying to determine a specific method to set the drive mappings the
way that I wanted, I really couldn't see any rhyme or reason to the way in
which drive mappings are configured.  The afsdsbmt.ini file is simple
enough.  The results of my efforts are different from what I would
expect though.

For example: At one point I had a Q: drive that is shown as not connected
in Windows explorer (big red X on the drive icon).  The drive shows in
"Drive Letters" on afscreds, but I cannot remove it.  The Q: drive doesn't
appear in afsdsbmt.ini.  Strange.

I suspect that Windows isn't correctly reporting/releasing available drive
letters.  I suspect this because I would get errors that drives were
already in use that were not reported as used.  A combination of rebooting
windows and changing drive letter mappings using only the GUI dialogs got
me back on track.

I do have a working AFS client now.  My problem was somehow related to
drive mapping.  (unless Jeff A. pipes up and says I am smoking crack)

So some sort of error in drive mappings caused the Cache Manager or the
client to give me the original "Error: 11862791 (AFS service my not have
started)" / "KTM_NOCM".

I have done enough tweaking on this I could probably repeat the problems I
had if someone needed a tester.  (perhaps PEBKAC? ;) )

This message is sent to the list mostly for posterity.  There wasn't much
on the net about the particular error code I was receiving.  Hopefully
some future person will find this useful.

Jason C. Wells