[OpenAFS] AMD64 fileserver segfaults

Andrej Filipcic andrej.filipcic@ijs.si
Mon, 15 Dec 2003 16:02:43 +0100 (CET)


I am trying to setup an openafs server on dual opteron with SuSE 9.0 for 
x86_64. With initial server setup, I have troubles with fileserver after 
the following command

bos create <server name> fs fs /usr/lib64/openafs/fileserver \
		               /usr/lib64/openafs/volserver  \
        		       /usr/lib64/openafs/salvager    \
                	       -cell <cell name> -noauth

One of fileserver threads uses 100% CPU. gdb shows:

Program received signal SIGSEGV, Segmentation fault.
0x0000000000461ab5 in rxi_ScheduleKeepAliveEvent (call=0xded4c)
    at ../rx/rx.c:5326
5326          call->keepAliveEvent = rxevent_Post(&when, 
rxi_KeepAliveEvent, call, 0);


(gdb) where
#0  0x0000000000461ab5 in rxi_ScheduleKeepAliveEvent (call=0xded4c)
    at ../rx/rx.c:5326
#1  0x0000000000461af1 in rxi_KeepAliveOn (call=0xded4b) at 
#2  0x0000000000458ef7 in rx_NewCall (conn=0x5d64d0) at ../rx/rx.c:1089
#3  0x0000000000427799 in VL_RegisterAddrs (z_conn=0x5d64d0, 
    spare1=0, ipaddr=0x7fbfffee20) at ../vlserver/vldbint.cs.c:1089
#4  0x000000000044b79a in ubik_Call (aproc=0x427760 <VL_RegisterAddrs>,
    aclient=0x5d66e0, aflags=0, p1=5954512, p2=0, p3=548682067488,
    p4=-4564397115262264220, p5=1071273902, p6=0, p7=1071273902, p8=0,
    p9=5912864, p10=548682067536, p11=10, p12=2, p13=548682067424,
    p14=5912864, p15=4243499, p16=5912864) at ../ubik/ubikclient.c:456
#5  0x000000000040be16 in Do_VLRegisterRPC () at ../viced/viced.c:1563
#6  0x000000000040c02b in InitVL () at ../viced/viced.c:1656
#7  0x00000000004098b3 in main (argc=-1073745264, argv=0x59de84)
    at ../viced/viced.c:541

If I replace the fileserver with version without threads, it seems to 

The afs client on the same machine has also problems (using working afs 
  afs: Tokens for user of AFS id 3202 for cell f9.ijs.si are discarded 
  (rxkad error=19270410)

I have also tried to run afs server in chrooted gentoo and the symptoms 
were the same. 
Kernel is suse 2.4.21. I have also tried 2.4.23 with no change.

Any ideas what is wrong?



   doc. dr. Andrej Filipcic,   E-mail: Andrej.Filipcic@ijs.si
   Department of Experimental High Energy Physics - F9
   Jozef Stefan Institute, Jamova 39, P.o.Box 3000
   SI-1001 Ljubljana, Slovenia
   Tel.: +386-1-477-3674    Fax: +386-1-425-7074