[OpenAFS] gcc reading beyond end of file on AFS

Edward Moy emoy@apple.com
Sat, 25 Jan 2003 10:46:12 -0800

Thanks for the info.

One other thing I've discovered is that if you remove the (two) -pipe  
arguments, it works.

And just to be complete, I should mention that I am compiling in a  
directory on a local disk, with symbolic links for the sources off into  
AFS.  So sprint.c is a symbolic link to the real sprint.c in AFS.
Edward Moy
Apple Computer, Inc.

(This message is from me as a reader of this list, and not a statement
from Apple.)

On Saturday, January 25, 2003, at 10:36 AM, RD Schaffer wrote:

>  I cannot explain technically what is going on. But I understand that  
> this is a bug in open afs, which I found a little while ago. If you  
> need a working version of afs to allow builds, you can use the arla  
> client. (I believe they already had this problem but fixed it.) I do  
> not know the schedule for a bug fix for openafs, but am interested to  
> know as well.
> On Saturday, Jan 25, 2003, at 10:13 Europe/Paris, emoy@apple.com wrote:
>> I'm trying to compile sources on an OpenAFS server.  It compiles the  
>> first half dozen files fine, but on a certain file, it seems to start  
>> reading beyond the end of file:
>> gcc -arch ppc -g -Os -pipe -no-cpp-precomp -arch ppc -pipe  
>> -I../../include   -c -o sprint.o sprint.c
>> sprint.c: In function `__sio_converter':
>> sprint.c:661: warning: cast from pointer to integer of different size
>> sprint.c: At top level:
>> sprint.c:742: stray '\215' in program
>> sprint.c:742: stray '\235' in program
>> sprint.c:742: parse error before numeric constant
>> sprint.c:742: stray '\325' in program
>> sprint.c:742: stray '\217' in program
>>     (lots more similar lines)
>> The file itself only has 741 lines.  Copying the file locally works  
>> fine.  Comparing the file (with cmp) show the file is correct.  Size  
>> and checksum all match.  Yet the file repeatably fails.
>> I have tried two different servers (Mac OS X and Linux) with the same  
>> results, so it's probably not a server problem.  So it probably a  
>> client problem.
>> I'm using Mac OS X with OpenAFS 1.2.8, and have tried in on Mac OS X  
>> 10.2 and 10.2.3.
>> Does this ring a bell with anyone?  What could gcc be doing that  
>> other programs don't seem to be affected.
> Email:    R.D.Schaffer@cern.ch
> Address:  LAL BAT 200        tel(Orsay): 33-1 64 46 8378
>                   BP 34                     tel(cern) : 41-22 76 71267
>                  91898 ORSAY
>                  France