[OpenAFS] lost contact with volume location server

Peter Schuller peter.schuller@infidyne.com
31 Jan 2003 18:35:54 +0100

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

> > Ah! Okay. Could that also happen if the afs daemon tried to call the
> > module before it is properly initialized?
> No.  It's not a question of CALLING the module, it's trying to unload
> the module..  The afs startup script shouldn't cause an oops, unless
> the module was previously loaded.  Similarly, the module should not
> oops if you shutdown AFS and then unload the module.  What WILL oops
> is:
>         insmod libafs.o
>         rmmod libafs.o

Ok. This is consistent with what I'm seeing.

> > If so, perhaps that's what is happening - module intialization fails fo=
> > some reason, even though it seems to insert correctly.
> Unlikely....

Ok. In any case, I'm stomped. I just tried changing the contents of
ThisCell to "stacken.kth.se", and the client worked perfectly.

I also tried configuring another machine as an AFS client in *my* cell,
and it also worked (this was the Windows client however).

BUT, I still cannot connect my client to my server... That is; I can
have a working AFS, and then ONLY change ThisCell back to pointing to my
cell, and it no longer works even though the cell works when accessed
from other clients.

Is it possible for the server and the client to conflict somehow, when
run on the same machine?

/ Peter Schuller, InfiDyne Technologies HB

PGP userID: 0xE9758B7D or 'Peter Schuller <peter.schuller@infidyne.com>'
Key retrival: Send an E-Mail to getpgpkey@scode.org
E-Mail: peter.schuller@infidyne.com Web: http://www.scode.org

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.2.1 (GNU/Linux)