[OpenAFS] Redhat 8 dual proc machine

Alexander J. Marsh ajmarsh@umich.edu
Tue, 11 Mar 2003 10:49:55 -0500


Hello,

I am having some problems getting OpenAFS to run on my dual PIII system. 
  First I tried using the RPMs but every time I tried to start up AFS it 
would fail and fill up /var/log/messages with a lot of incomprehensible 
strings of numbers.  I figured the openafs-kernel RPM would need to be 
built for SMP systems.  Is there such an RPM out there?

Next I tried to compile from src with ./configure 
--with-linux-kernel-headers=/usr/src/linux-2.4, make, make install. 
That seemed to go ok.  Then I copied the afs start script over form one 
of my working single proc machines.  ./afs start produces the following 
error

AFS module /usr/vice/etc/modload/libafs-2.4.18-26.8.0smp.mp.o does not 
exist. Not starting AFS.

in the /usr/vice/etc/modload folder there is a file called 
libafs-2.4.18-26.8.0.mp.o, but not libafs-2.4.18-26.8.0smp.mp.o.  I have 
tried just making a symlink but it does not work either.

Any clues you can provide me to get this working would be greatly 
appreciated.  Thanks in advance.




   ++alex





Alexander J. Marsh
Unix Systems Administrator
University of Michigan DLPS
p 734.763.0246
c 734.368.3839