[OpenAFS] OpenAFS server on SuSE 8.2

Jan Hrabe hrabe@mail.magalien.com
Sun, 7 Sep 2003 23:27:44 -0400


I am having trouble installing the OpenAFS server 1.2.10 on a SuSE 8.2 
machine.  The compilation (using Transarc path) seemed to go fine and the 
kernel module loads OK.  However, when installing the server (this is the 
first machine in a new cell), following the procedure from the manual, I 
could not create users afs and admin.  kas responded:

ka> create afs
Verifying, please re-enter initial_password:
Creating user afs  : [____] server or network not responding
ka> examine afs
examine: server or network not responding getting information for afs.

I found out that kaserver (as well as ptserver and vlserver) were not 
running, only the bosserver and buserver.  The BosLog recorded:

Sun Sep  7 19:00:54 2003: kaserver exited on signal 11
Sun Sep  7 19:00:54 2003: kaserver exited on signal 11
Sun Sep  7 19:00:54 2003: BNODE 'kaserver' repeatedly failed to start, 
perhaps missing executable.

Similarly for the other two.  I tried to run kaserver manualy but got a 
segmentation fault:

davinci:/usr/afs/bin # ./kaserver
Segmentation fault

I then tried to compile kaserver with CC=gcc -g and got:

(gdb) run
Starting program: /temp/openafs/openafs-1.2.10/src/kauth/kaserver
Program received signal SIGSEGV, Segmentation fault.
0x400a5b99 in _int_malloc () from /lib/libc.so.6
(gdb) where
#0  0x400a5b99 in _int_malloc () from /lib/libc.so.6
#1  0x400a4898 in malloc () from /lib/libc.so.6
#2  0x08070c25 in rx_Init ()
#3  0x0805bb76 in ubik_ServerInitCommon (myHost=-1727986166, myPort=23579,
    info=0xbfffe800, clones=0xbfffe6c8 "", serverList=0x0,
    pathName=0x8095f60 "/usr/afs/db/kaserver", dbase=0x409) at ubik.c:262
#4  0x0805ba26 in ubik_ServerInitByInfo (myHost=-1727986166, myPort=23579,
    info=0xbfffe800, clones=0xbfffe6c8 "",
    pathName=0x8095f60 "/usr/afs/db/kaserver", dbase=0x809872c) at 
#5  0x0804a5da in main (argc=1, argv=0xbfffeb84) at kaserver.c:332
#6  0x400438ae in __libc_start_main () from /lib/libc.so.6

The /usr/afs/etc/CellServDB file contains:
>nil.pvt.lij.edu        #Cell name    #davinci.pvt.lij.edu

and /usr/afs/etc/ThisCell has:

Any help would be greatly appreciated!

Thanks a lot,

Jan Hrabe
Center for Advanced Brain Imaging
Nathan Kline Institute
Orangeburg, New York