Re[2]: [OpenAFS] volume exists without a VLDB entry

Jeffrey Hutzelman
Fri, 23 Jan 2004 12:18:38 -0500

On Friday, January 23, 2004 10:35:09 +0000 Ron Croonenberg 
<> wrote:

>> If the volume has no VLDB entry, then you won't be able to refer to it by
>> name.  You should be able to refer to it by ID, though, and if it appears
>> with several names and different ID's, you'll end up having to do that
>> anyway.
>> If you don't actually care about the volume and just want to delete it,
>> you can use 'vos zap' to remove the volume itself without trying to
>> update the VLDB.  Of course, you'll still have to refer to it by ID,
>> since the name lookup requires a VLDB entry.
> Ok I tried that :
> (here's what I tried)
> [root@afs]# vos zap -server -partition /vicepa -id
> 536871521 Could not start transaction on volume 536871521
> Volume needs to be salvaged
> Error in vos zap command.
> Volume needs to be salvaged
> then I tried this :
> [root@afs]# vos zap -server -partition /vicepa
>    -id 536871521 -force
> vos: forcibly removing all traces of volume 536871521, please
> wait...failed with code 2.

OK.  "code 2" is ENOENT on most systems.  Reading the code, it looks pretty 
likely that this means the volume already doesn't exist, and the only 
remnant of it is the Vxxx.vol file in the top-level of the partition.  To 
confirm this, you can run 'bos salvage a -volume 536871521 
-showlog'; the resulting log should include something about "No applicable 
vice inodes on partition /vicepa".  If this is the case, you can safely 
just rm /vicepa/V0536871521.vol

-- Jeffrey T. Hutzelman (N3NHS) <>
   Sr. Research Systems Programmer
   School of Computer Science - Research Computing Facility
   Carnegie Mellon University - Pittsburgh, PA