[OpenAFS] Commercial use of OpenAFS ?

Systems Administration sysadmin@contrailservices.com
Wed, 8 Sep 2004 11:23:28 -0600

> Linux Crash...
> Tests done on LFS 5.1.1 (2.4.27 kernel + libata patch, with or without
> grsecurity patch). I use a diskless client configuration, no swap, 
> ~200MB
> for the system (total 2GB RAM), AFS cache is 25MB. I tried to move 
> around a
> 1,5GB file inside the afs directory. Never finished the move. AFS 
> client /
> Linux hangs, and I have reboot the system.

"Linux hangs" is a bit nebulous - is this a hang of the client shell 
running the process or is it a total deadlock of the kernel?  You can 
check this by using a virtual terminal if you are using tty console 

Have you tried cycling the fileserver process (bos shutdown, wait for 
client to timeout then startup again)?  I have a persistent unsolved 
issue with 1.2.11 which Derek has been helping me debug (very slowly) 
and I'm curious to know if your hangups might be of similar origin.

Also you should try running 'strace' on the client to see what system 
call, if any, the hangup is associated with.