[OpenAFS] application error message with Windows XP

Alan Wehmann wehmann@fnal.gov
Mon, 27 Sep 2004 21:21:51 -0500 (CDT)

The problem turned out to be non-existant "IBM\AFS\etc." directories
in the PATH environmental variable on my laptop.  When I removed them
and restarted the computer, the OpenAFS 1.3.71 client worked.

I don't know how those PATH entries got there.  Perhaps the installer
for the earlier version of the client (1.3.64) put them there?

Below is the exchange that prompted this action.

<>This area didn't exist on my laptop.  I edited the PATH variable and
<>removed the entries with "\IBM\AFS\" in them.  After that, I restarted
<>the computer and the OpenAFS client 1.3.71 worked!
<>Please thank the expert for suggesting this approach--even although it
<>was indirect.
<>> Date: Mon, 27 Sep 2004 10:03:11 -0500 (CDT)
<>> From: HelpDesk <AREmail@fnal.gov>
<>> Reply-to: HelpDesk <helpdesk@fnal.gov>
<>> X-Priority: 3
<>> The expert has added the following information to your request.  
<>> Please review carefully as additional information may be requested.
<>> To add additional information, visit http://helpdesk.fnal.gov 
<>> ___________________________________________________________________
<>> Note To Requester: Hi Alan,
<>> From your init log, it looks like the following is in your PATH:
<>> C:\PROGRA~1\IBM\AFS\Client\Program
<>> Does this area exist?  If so, can you rename the "IBM" folder 
<>> and see if the problem may be that the wrong execs are getting called?
> Date: Tue, 21 Sep 2004 18:11:12 -0400
> From: Jeffrey Altman <jaltman@columbia.edu>
> Cc: openafs-info@openafs.org
> It looks fine.  the log is pretty clear though.  The afsd_service.exe
> is bound a loopback adapter and the IP address to which the 
> afsd_service.exe is bound is disappearing.  That means either the
> loopback adapter is being disabled or the IP address is being changed.
> That is why the service crashes.
> Jeffrey Altman

Alan Wehmann
(630) 840-4692
(630) 840-6039 (fax)
snail-mail: M.S. 220
PO Box 500, zip 60510-0500