[OpenAFS] Debian install problem: ptserver won't start

Scott Fritzinger scottf@unr.edu
Wed, 20 Apr 2005 11:17:07 -0700

Lars (and others who have responded),

I was using Debian stable, which was, as mentioned, using the 1.2.3 
release. I removed all of 1.2.3 and tried the Debian testing branch 
(which uses 1.3.18). I ran into a problem with bosserver not finding the 
"<default>" cell when it is being shut down. afs-newcell had problems 
because of this it seems.

So, I removed it all, added the openafs.org reposity to my sources lists 
and installed 1.2.13, which appears to have worked with exception of the 
kernel modules. I'm currently running 2.6.7 and the 
openafs-modules-source won't compile because of the changes to 
sys_call_table apparently in the new kernel.

I am moving back down to 2.4.27 (something I've been meaning to do for a 
while. Can you tell this is the experimental server? :-) and will try 
again. I'll write in to give a status update when 2.4.27 is installed 
and the modules are loaded.

Thanks to everyone for replying and providing feedback.


Sergio Gelato wrote:
> * Lars Schimmer [2005-04-20 10:10:08 +0200]:
>>Scott Fritzinger schrieb:
>>| All,
>>| I'm having a "bang your head against a wall" problem when installing
>>| OpenAFS on Debian from the Debian repository.
>>First - which one? I strongly suggest the experimental sources and version
>>1.3.81 of OpenAFS.
> Very good question. In particular, Debian stable ("woody", 3.0r5) still 
> ships with OpenAFS 1.2.3 packages which you most definitely should not use. 
> Get the 1.2.13 packages from openafs.org if you're using woody.
>>And to your problem - if the server is multihomed, try the netrestrict 
>>file, in
>>which all IPs are listed that OpenAFS shouldn't listen to. More info on the
>>www.openafs.org website documentation. In Debian that file should rest in
> Or in /var/lib/openafs, depending on which build of the .deb's you are using.
> I agree that NetRestrict can be desirable for a multihomed server, but I don't
> think it's the main issue here. Things ought to work, if a little less
> efficiently, without any explicit NetRestrict configuration.
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info