[OpenAFS] Can't Map AFS drive

Charles McIntyre mcintyre@ucsc.edu
Fri, 05 Aug 2005 12:44:03 -0700


We're back at this trying to figure out how to=20
get OpenAFS to run in our environment.  We=20
thought it was some 3rd party application that=20
was causing a conflict, but now I'm not sure that's the case.

Currently, I'm testing this with a base install=20
XP Pro SP2 with MIT KfW and OpenAFS 1.3.8600=20
installed.  I've also tried 1.3.85, 1.3.84, and=20
1.3.73 and get the same problem.  I've also tried=20
installing OpenAFS with "Integrated Login"=20
checked and unchecked and using and not using KfW=20
with the various versions.  In the past, I=20
noticed that if KfW got the AFS tokens then=20
OpenAFS wouldn't work correctly, so normally I=20
don't have KfW get AFS tokens.  I've tried it=20
both ways with multiple versions and nothing's working.

The current symptom that we're seeing is when we=20
try to map a drive using the afscreds systray app=20
to a afs cell path (i.e.=20
/afs/cats/users/q/ictest) the machine hangs every=20
time.  Trying to map using "net use x:=20
\\afs\cats\users\q\ictest" or by using a submount=20
(which I know you don't like) it does the=20
same.  I can mount a drive to /afs, but only our=20
cell (cats.ucsc.edu) shows up and when I try to=20
open that directory, the machine hangs.

This has been a problem for us ever since SP2 with any OpenAFS client.

Any ideas?

Thanks in advance!


At 08:01 AM 7/8/2005, Jeffrey Altman wrote:
>If the MLA is there its a non-issue.
>Browse \\AFS and see what names are offered.
>Charles McIntyre wrote:
> > We always reinstall the MLA after imaging.  We were just curious if the
> > sysprep/ghost MLA deletion was causing an additional problem, or if this
> > is a non-issue.


Charles McIntyre
PC/UNIX Systems Engineer
Instructional Computing
Information Technology Services, UCSC
ph: 831/459-5746
fx: 831/459-2914

got a question? see http://ic.ucsc.edu/help =20