[OpenAFS] SuSE 9.3 asetkey and aklog

ted creedon tcreedon@easystreet.com
Fri, 8 Jul 2005 08:44:40 -0700

SUSE asetkey compiled fine, the problem was aklog both in the 1.3.84 for
openafs and afs-krb5.rpm from SUSE. I did a regen.sh in the openafs tree but
aklog still doesn't build or install.

Regarding autoconf I'm on the latest SuSE release, 9.3 - autoconf 2-59.80. I
used the source rpm's for asetkey and aklog from SuSE's afs-krb5 integration

Since the old .configure shipped with SuSE 9.3 works for asetkey but not for
aklog (includes too many libraries, hack the gcc line) is anyone willing to
do the minor fix?

The 9.3 afs-krb5.rpm v 2.05 from SuSE is technically incompatible with 1.84
because of the additional "overwrite" argument in afsconf_ADDKEY(). 2.05
does run with 1.84 but the overwrite argument is obviously undefined in that


-----Original Message-----
From: openafs-info-admin@openafs.org [mailto:openafs-info-admin@openafs.org]
On Behalf Of Ken Hornstein
Sent: Friday, July 08, 2005 8:15 AM
To: openafs-info@openafs.org
Subject: Re: [OpenAFS] SuSE 9.3 asetkey and aklog 

>Looks like the problem is solved and in the CVS tree.

It was solved before ... unless you were running an ancient autoconf.
I suspect your problem was that you never regenerated the top-level
configure script.

>Perhaps aklog and asetkey could be incorporated into 1.4?

Didn't we cover this already?  aklog will, asetkey won't (unless someone
else wants to do it - I'm not interested in digging through autoconf 2.13
documentation to figure out which macros I'm allowed to use).

OpenAFS-info mailing list