[OpenAFS] -orphans parameter doesn't work with bos salvage

Tobias Pfeiffer BoteDesSchattens@web.de
Fri, 18 Nov 2005 17:49:16 +0100

Hash: SHA1


I am running OpenAFS on Debian GNU/Linux Sarge (Version 1.3.81-3sarge1)
and I have the following problem: I have mounted a volume usr.schluempfe
to /afs/mycell.de/home/s/schluempfe, next to many other volumes that are
mounted to users' home directories. Now the problem is the following:

root @ ~ # ls /afs/mycell.de/home/s/
schluempfe  subhi  suri

root @ ~ # ls -l /afs/mycell.de/home/s/
ls: /afs/aska.cidsnet.de/home/s/schluempfe: File or directory not found
drwxrwxrwx  19 subhi root 2048 2005-11-16 11:48 subhi
drwxrwxrwx  11 suri  root 2048 2005-09-21 12:09 suri

root @ ~ # ls /afs/aska.cidsnet.de/home/s/schluempfe
ls: /afs/aska.cidsnet.de/home/s/schluempfe: File or directory not found

So somehow I cannot access the contents of the volume. That is one
problem. I tried to salvage the volume:

bos salvage files /vicepa usr.schluempfe -showlog
Starting salvage.
bos: salvage completed
@(#) OpenAFS 1.3.81 built  2005-05-14
11/18/2005 17:41:59 STARTING AFS SALVAGER 2.4 (/usr/lib/openafs/salvager
/vicepa 536871092)
11/18/2005 17:41:59 1 nVolumesInInodeFile 28
11/18/2005 17:41:59 SALVAGING VOLUME 536871092.
11/18/2005 17:41:59 usr.schluempfe (536871092) updated 10/28/2005 09:35
11/18/2005 17:41:59 totalInodes 603
11/18/2005 17:41:59 Found 599 orphaned files and directories (approx.
6339 KB)
11/18/2005 17:41:59 Salvaged usr.schluempfe (536871092): 599 files, 6339

This apparently changes nothing, the situation is the same as before.
Since the orphaned files seem to be the user's data (I doubt he has
collected more than 6339 KB of data), I tried to restore the orphaned files:

root @ ~ # bos salvage files /vicepa usr.schluempfe -showlog -orphans attach
Can't specify -orphans for MR-AFS fileserver

The problem is: I have no idea what MR-AFS is. I actually don't run it
for sure. Anyone an idea where this comes from and how I can change this
behaviour? (No, I have no backup of this volume; I just want the
orphaned files back.)


- --
I may disagree with what you have to say, but I shall
defend to the death your right to say it.
~                   -- Voltaire
Version: GnuPG v1.4.1 (GNU/Linux)