[OpenAFS] 1.4.0 rc6 Solaris 10 x86-64 issues?

Kris Kasner tkasner@qualcomm.com
Thu, 6 Oct 2005 10:42:00 -0700 (PDT)


I'm working on getting Solaris 10 x86-64 ready to deploy in our environment. 
I'm having trouble getting OpenAFS to work correctly when Solaris is booted 
under the 64bit kernel (the default for the opteron boxes we're planning on 
using). It works perfectly when booted under the 32bit kernel. I've done 
extensive searching, I've tried rc4 rc5, rc6, 1.3.81, 1.3.87, compiling with 
both SUNWspro cc and gcc:
cc: Sun C 5.7 Patch 117837-03 2005/03/23
gcc (GCC) 3.4.2

Nothing seems to change the results.. 32bit works, 64bit can talk to the afs 
servers (vos exa root.afs returns the same data under 64bit as my SPARC 
systems, or the x86 booted in 32bit), but reports "No such device" when trying 
to cd to an afs directory. Booting with "-fakestat" allows me to cd, but files 
show up empty (cat some_text_file returns absolutely nothing..) I've tried a 
memory only cache, also with no change.

I'm building on a Sun W2100z with 2 AMD Opteron 252's (2.6ghz), on Solaris 10 
GA with kernel patch 118844-08.

Any chance anyone has seen this before, or have any suggestions on what else to 

Thanks in advance for any help!


Thomas Kris Kasner                  Qualcomm Inc.
UNIX Systems Administration 	    5775 Morehouse Drive
 				    San Diego, CA 92121

 	All of the buildings, all of the cars
 	  Were once just a dream
 	    In somebody's head	-- Peter Gabriel, Mercy Street