[OpenAFS] OpenAFS 1.4.1 RC1 Cache on OS X 10.4.2

Derrick J Brashear shadow@dementia.org
Mon, 24 Oct 2005 13:22:38 -0400 (EDT)

I doubt it's an AFS cache problem as opposed to an issue where permission 
denied is being misinterpreted and the result cache in either internal AFS 
or MacOS kernel filesystem code

  On Mon, 24 Oct 2005, Mike Bydalek wrote:

> I just finished installing a test OS X 10.4.2 client with 1.4.1-rc1, and I 
> seem to be having some strange caching issues.  Basically, on the server, I 
> have a public/ directory, and within that directory is a scripts/ directory. 
> Well, what happened was I tried to run the script from the Mac, it failed, so 
> I tweaked it on the server, and then tried to re-run it on the Mac, and then 
> it reported 'script.sh not found'.   Even weirder is that if I did an 'ls' it 
> listed it, but if I did a 'ls -al' it listed all the other files in there, 
> but that one file, and reported an error 'ls: script not found'
> So, I did some testing and basically it seems there is a caching problem.  If 
> I create one file on the server, cat it on the client, modify it on the 
> server, and then re-cat it on the client, the changes aren't acknowledged.
> My question is, before I submit a bug report, what's the proper way to clear 
> the cache on the Mac client?  I see you can delete the cache/ items, but 
> everything I've seen says to be sure afsd isn't running, which I don't know 
> the proper way to shut it down on the Mac clients (no init script).
> Any ideas?  Rebooting is a pain :)
> -Mike
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info