[OpenAFS] Openafs 1.4.0-rc7 Success on Redhat Enterprise 4 EM64T

Derek Atkins warlord@MIT.EDU
Mon, 24 Oct 2005 17:44:26 -0400

Um, rpmbuild --rebuild should be a sufficient test.  Well, that and
then testing the RPMs. ;)


Quoting Lee Damon <nomad@crow.ee.washington.edu>:

> I haven't been following this thread at all but if you want I can try 
> to build these RPMs on the x86_64 box I'm playing with.  I don't have 
> a lot of time to translate instructions in an entire mail thread but 
> if you have a cookbook you want tested I'm available.
> nomad
> Derek Atkins wrote:
>> Quoting "Karl E. Kelley" <kekelley@iastate.edu>:
>>> I didn't want to try 1.4.0-rc5 on a system already running 1.4.0-rc7,
>> Well, you could try the 1.4.0 RPMs, as they've been finished.  However
>> the real point was to make sure that you could rebuild my RPMS on
>> x86_64 and that they would work.
>> Also, the 1.4.0 RPMS are done.  There's time to get changes into the
>> 1.4.1 RPMs....
>>>  - The openafs-client rc script doesn't provide the cache and afsd
>>>    configuration that the rc script that has been supplied with openafs
>>>    previously, and only provides 2 configuration parameters, AFSD_ARGS and
>>>    BOSSERVER_ARGS in /etc/sysconfig/openafs, not all the various parameter
>>>    settings for routines in /etc/init.d/afs, which I found very convenient
>>>    for providing a simple way to configure afsd.   I hope these are put
>>>    back in before 1.4.x goes GA.  If they don't, I will have to put them
>>>    back in myself and rebuild the rpms.
>> I dont understand what configuration you think you need that you
>> can't set in the AFSD_ARGS and BOSSERVER_ARGS.  Could you please
>> let me know?
>>>  - The README in the openafs-kernel-source is quite out of date as far
>>>    as telling how to install a rebuilt openafs kernel module, which is
>>>    obviouly different now the the openafs kernel modules are actually
>>>    being installed in /lib/modules, instead of in /usr/vice/etc/modload.
>> Can you send me a patch for this, or at least suggest better text?
>> There's also the "rpmbuild -bb --target=i686 openafs...src.rpm" to
>> build a kernel-module RPM for the currently-running kernel.
>>>  - to reiterate, the multiple openafs-kernel modules will cause a problem
>>>    with up2date, and I realize why that was done, but the only way I can
>>>    see is to put only the lowest kernel versions on the proxy server
>>>    and force everyone to recompile their own openafs kernel module 
>>> for newer
>>>    kernels, which isn't as good as it works now.
>> Why will this cause a problem with up2date?  Wont up2date already try
>> to install the most-recent kernel?  As I asked in my last email, how
>> does up2date deal with the redhat-distributed LKM RPMS?  Red hat must
>> have already solved this problem....
>>> Other than the above, openafs 1.4.0-rc5 seems to be working on:
>>> kekelley@motley.ait% uname -a
>>> Linux motley.ait.iastate.edu 2.6.9-22.EL #1 Mon Sep 19 18:20:28 EDT 
>>> 2005 i686 i686 i386 GNU/Linux
>> I was hoping to get an answer about x86_64, not x86.  But thanks.
>> -derek

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord@MIT.EDU                        PGP key available