[OpenAFS] windows client hangs

David Bear David.Bear@asu.edu
Thu, 22 Sep 2005 15:52:15 -0700

just today, starting this morning openafs on windows xp hangs.

I'm using openafs 1.3.84. Its been installed for a while. Its been
running fine.

Today, when I started windows, there was no \\afs unc available. I
opened a process list and noticed the afsd_service process taking 99%
of the cpu.

I went into the service control manager and tried to stop the afs
client service. However, all controls were 'greyed out', futher
messages said the openafs client was still starting.  This lasted for
about an hour. So I shutdown and restarted. Still openafs service is
listed is starting, but it never starts.

so, I went into control panel to remove afs. During the remove
operation I get the error message that openafs (transarcAFSDeamon)
could not be stopped, verify that you have sufficient priveledges.
Well, I do have administrator priveledge. Don't know of any more that
I can grant myself on windows.

I've tried to kill the process through the task manager. no go.

I've looked through the afsd_init.log -- here's the tail of that.
9/22/2005 3:15:51 PM: Maximum number of multiplexed sessions is 50
9/22/2005 3:15:51 PM: Maximum number of VCs per server is 100
9/22/2005 3:15:51 PM: SMB authentication type is EXTENDED
9/22/2005 3:15:51 PM: RX maximum MTU is 1260
9/22/2005 3:15:51 PM: ConnDeadTimeout is 60
9/22/2005 3:15:51 PM: HardDeadTimeout is 120
9/22/2005 3:15:51 PM: LAN adapter number 3
9/22/2005 3:15:51 PM: Using >AFS< as SMB server name
9/22/2005 3:15:51 PM: First Network address 95a94e39 SubnetMask
9/22/2005 3:15:51 PM: rx_SetMaxMTU 1260 successful
9/22/2005 3:15:51 PM: Cache File "C:\WINDOWS\TEMP\AFSCache" already
9/22/2005 3:15:51 PM: Existing File Size: 00000000:071787AC
9/22/2005 3:15:51 PM: Granularity - 10000
9/22/2005 3:15:51 PM: Reusing existing AFS Cache data: Base Address =
9/22/2005 3:15:51 PM: Validating Cache Contents

Can anyone tell me how to break out of this catch22 situation? Can't
stop openafs to uninstall it. Can't start it to use it.

David Bear
phone: 	480-965-8257
fax: 	480-965-9189
College of Public Programs/ASU
Wilson Hall 232
Tempe, AZ 85287-0803
 "Beware the IP portfolio, everyone will be suspect of trespassing"