[OpenAFS] Unable to build user-space RPMs from source RPM (RHEL3, 1.40)

Derek Atkins warlord@MIT.EDU
Fri, 21 Apr 2006 13:49:21 -0400

Oh, I'll also add that the user-space RPMS are kernel agnostic.  You shouldn't
need to rebuild them, especailly not just because the don't "match up with
[your] kernel".

I'll also note that the 1.4.1 RPMS should be available really really soon,
and I've built those against all the updated kernels to-date.  Or at least
all of them that I've found.


Quoting Drew Leske <dleske@uvic.ca>:

> Hi all,
> Apologies if this has been "asked and answered".  I looked at both the info
> and devel lists and didn't see anyone with my problem, nor do I see it
> covered in the docs.
> We have a cluster based on Red Hat Enterprise Linux 3.  I need to build the
> RPMs from the source RPM so as to match up with our kernel--the prebuilt
> RPMs typically don't match what we have at the time of install--and building
> from source (tarball) isn't an option due to the many machines to which AFS
> needs to be deployed.
> Last time I did this, it was version 1.2.13 and the procedure was basically:
>  # rpm -ivh openafs-1.2.13.src.rpm
>  # cd /usr/src/redhat
>  # rpmbuild -ba SPECS/openafs-1.2.13.spec
>  # cd RPMS/i386
>  # rpm -ivh openafs-{,client,compat,devel,kernel}.*.rpm
> It looks like the usage of the spec has changed a bit, and now I'm somewhat
> lost.  The 'rpmbuild' invocation above failed with:
>  Can't exec "aclocal": No such file or directory at
>  /usr/share/autoconf/Autom4te/General.pm line 498, <GEN0> line 259.
> I learned in another thread that to build the kernel modules successfully
> for the i686 CPU I need to do the following:
>  # cd /usr/src/redhat
>  # rpmbuild -ba --target=i686 SPECS/openafs.spec
> This successfully creates the kernel module RPMs:
>  #  find RPMS -type f
>  RPMS/i686/openafs-kernel-1.4.0-2.4.21_32.EL_1.i686.rpm
>  RPMS/i686/openafs-kernel-smp-1.4.0-2.4.21_32.EL_1.i686.rpm
>  RPMS/i686/openafs-kernel-hugemem-1.4.0-2.4.21_32.EL_1.i686.rpm
> But as you can see, this does not build the rest of the RPMs I expected, and
> I can't find out how to do that.  I've looked at the spec file and I've
> tried defining "build_userspace" but I get the same error as above, even if
> I specify the target.
> Any help would be much appreciated.
> Thanks in advance,
> Drew.
> --
> Drew Leske :: Systems Group/Unix, Computing Services, University of Victoria
>  dleske@uvic.ca / +1250 472 5055 (office) / +1250 588 4311 (cel)
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord@MIT.EDU                        PGP key available