[OpenAFS] ioctl on afs_ioctl blocking forever

David Broudy dave@broudy.net
Sat, 22 Apr 2006 12:14:46 -0600

After deciding that openafs was never going to work quite right with my 
nat a few days ago (thanks Jeffery), and that I probably need to create 
a vpn anyway, I did and changed the addresses to run over that. It 
worked great for a couple days, but now aklog and other afs tools are 
blocking forever on:

open("/proc/fs/openafs/afs_ioctl", O_RDWR) = 4

This is after aklog already produced output:

Authenticating to cell broudy.net (server minerva.vpn.broudy.net).
We've deduced that we need to authenticate to realm BROUDY.NET.
Getting tickets: afs/broudy.net@BROUDY.NET
About to resolve name dave.admin to id in cell broudy.net.
Id 1
Set username to AFS ID 1
Setting tokens. AFS ID 1 /  @ BROUDY.NET

This is happening on all my clients, and tcpdump doesn't seem to show 
any afs related network traffic while this is happening. I've tried this 
with and without afsdb configured. I see this question was asked before 
on the list, but there was never an answer posted that I can find.

Thanks in advance,

Dave Broudy
Phone: 303.278.0908      Mobile: 703.401.5955        Fax: 303.674.6840
AIM/YIM: dbroudy