[OpenAFS] service start failure

Rodney M Dyer rmdyer@uncc.edu
Tue, 29 Aug 2006 21:55:16 -0400

We recently encountered an issue where the AFS service wouldn't start and 
Windows would throw a Dr. Watson error.  The users laptop we were looking 
at ran Windows 2000.  After a few hours scratching my head and wearing out 
my fingers I noticed that the laptops computername was 12+ characters (i 
don't remember the actual number).  I changed the computername to 3 
characters and that solved the problem.

I thought that using the loopback adapter with name "AFS" solved the issue 
with needing a special "short" computername.  I guess not.

Note:  I was trying to install


At 09:14 PM 8/29/2006, Jeffrey Altman wrote:
>There is a bug in 1.4.2-rc1 that will be fixed in 1.4.2-rc2.
>That is your problem.
>The How To Debug OpenAFS instructions are in the release notes
>that are published next to the link you used to download OpenAFS
>and installed on your hard drive.  Start
>Jeffrey Altman
>David Bear wrote:
> > I have a new XP SP2 installation that is fully patched via microsoft.
> > The first application installed after patching was openafs 1.4.2
> > (whatever version is on the download link from openafs.org).
> >
> > The installation proceeded without error. However, the service still
> > fails to start. So I installed the debug version. Now I need help
> > decoding what the debug version says. (the initial cryptic error had
> > something to do with a failure in ntdll.dll)
> >
> > I've lost track of the 'how to debug openafs' instructions though.
> > Sorry to pester the list but any pointers?
> >
> > yes, I turned off the xp firewall
> > yes I have a fully routable address
> > no I do not have any nat
> > no, I have not tried access any afs volumes, the client services just
> > fails to start
> >