[OpenAFS] multiple fileservers using chbind: almost there, need advice

Adam Megacz megacz@cs.berkeley.edu
Mon, 09 Jan 2006 22:15:51 -0800

Everything is going really well.  Most stuff works: bosserver starts
up, ptserver and vlserver are working fine.  The only issue is
grabbing the partition list -- this command hangs if bosserver was
started in a chbound environment, but works fine if it is not:

  vos create 
        -server research.cs.berkeley.edu 
        -partition /vicepc 
        -name root.cell 
        -maxquota 20000000 
        -cell research.cs.berkeley.edu 

After a while it times out with:

  Could not fetch the list of partitions from the server

Any idea what might cause this behavior?  I've tried restarting the
openafs client on the machine from which I'm issuing all these
commands.  Running "vos lista" shows no addresses (presumably because
there are no volumes... yet).

I also tried adding the interfaces to NetInfo and NetRestrict (in
addition to chbinding... just in case chbind doesn't "hide" unusable
interfaces) and that didn't help.

  - a

PGP/GPG: 5C9F F366 C9CF 2145 E770  B1B8 EFB1 462D A146 C380