[OpenAFS] File corruption, 1.4.1 on linux

Miles Davis miles@CS.Stanford.EDU
Fri, 12 May 2006 11:57:05 -0700

On Thu, May 11, 2006 at 04:51:30PM -0400, Derrick J Brashear wrote:
> On Thu, 11 May 2006, Miles Davis wrote:
> >Sorry -- clone on same site. I haven't tried making a clone on another 
> >site yet
> >(I didn't used to have it replicated, but decided to test that out).
> So if the copy in the RO had not also gone bad I would have been scared.
> Is it changing size, or content?

Content only, it seems.
> Use md5 and ls -l on the file. You can find it with help from 
> /afs/andrew.cmu.edu/usr/shadow/volid.pl (give it the RW's volume id number 
> as input)

The following is the output of (date, ls, md4sum, and rpm -K)

- good ----------------------------------------------------------------------
Fri May 12 11:52:37 PDT 2006
-rw-r--r--  1 miles users 2023546 May 20  2005 pam-0.79-8.i386.rpm
46c4df5bd02e2b0608bca68f56f8d00c  pam-0.79-8.i386.rpm
pam-0.79-8.i386.rpm: sha1 md5 OK

- bad ----------------------------------------------------------------------
Fri May 12 11:52:48 PDT 2006
-rw-r--r--  1 miles users 2023546 May 20  2005 pam-0.79-8.i386.rpm
b6a9d86f04484dc76c818b358ceaaa82  pam-0.79-8.i386.rpm
error: pam-0.79-8.i386.rpm: headerRead failed

I seem to be able to corrupt the file almost at will with a flushvol. I've 
tried watching some of the files on the server side, but I haven't been able to 
catch one in the act yet (a watched file never corrupts...)

// Miles Davis - miles@cs.stanford.edu - http://www.cs.stanford.edu/~miles
// Computer Science Department - Computer Facilities
// Stanford University