[OpenAFS] Linux-VServer and openAFS

"Einar S. Idsų" esi@itk.ntnu.no
Tue, 16 May 2006 11:57:05 +0200


I've just joined this list hoping to get some help with making openAFS
work with a vserver-kernel. Everything below concerns the vserver host,
not the guests.

>From the maillist archive, I was able to compile a working openafs module:

I am following the Gentoo howto for setting up openAFS:

In the first step in starting the AFS server, I am to run 'bosserver
-noauth &'. This results in the creation of two symlinks:
/etc/openafs/CellServDB -> /etc/openafs/server/CellServDB
/etc/openafs/ThisCell -> /etc/openafs/server/ThisCell

and one file:

At this point bosserver dies. I am therefore unable to progress.

(Note: The path in the howto says /usr/vice/etc/, but this has been
changed to /etc/openafs).

I have tried to recompile openafs with and without the fix in the
maillist archive above, but I keep getting the same result: Two
symlinks, one file and one dead bosserver.

Apparently bosserver is very unhappy on my server:
# bosserver -help
Segmentation fault

A bt on the coredump gives:
#0  0x00000000004067cf in bozo_rxstat_userok ()
#1  0x00002aaaaacf2644 in __libc_start_main () from /lib/tls/libc.so.6
#2  0x00000000004057ea in ?? ()
#3  0x00007fffffe225a8 in ?? ()
#4  0x000000000000001c in ?? ()
#5  0x0000000000000002 in ?? ()
#6  0x00007fffffe227e1 in ?? ()
#7  0x00007fffffe227eb in ?? ()
#8  0x0000000000000000 in ?? ()

My setup:
Dual Opteron 250
Gentoo Linux
2.6.15-vs2.0.1-gentoo-r5 SMP kernel

On similar hardware, but running a non-vserver kernel, bosserver works

Does anyone have any clue what is going on, how it can be fixed, or how
I can help get it fixed? I am no capable programmer, but I am more than
happy to fiddle about with stuff on my server to get things working :)