[OpenAFS] browsing \\afs is flaky with openafs-1.4.1 on xp sp2

Christopher Allen Wing wingc@engin.umich.edu
Tue, 16 May 2006 18:19:57 -0400 (EDT)

(I just entered a bug report with this same text as bug #31903)

I am testing the OpenAFS Windows client on a XP SP2 machine which should be 
reasonably up to date with patches.  I cannot reliably browse the '\\afs' root 
in Windows Explorer.  Sometimes this works, but other times I get the error:

 	\\afs is not accessible. You might not have permission to use this
 	network resource. Contact the administrator of this server to find
 	out if you have access permissions.

 	The network path was not found.

Freelance mode is enabled.  I have tried with and without integrated logon, it 
seems equally likely to misbehave.

What I am trying to do is just go to "Run" in the start menu, and enter 
'\\afs'.  Occasionally this succeeds and I can see the list of freelance mount 
points.  Most of the time it fails with the above error.

What does work properly all the time is going directly to an AFS cell, by 


in the "Run" prompt.  Other than this weird \\afs browsing problem, the AFS 
client seems to be working correctly.

Interestingly, I _can_ get to the root (\\afs) if I first open up an Explorer 
window, by entering the UNC path:


and then clicking on the "Up" button in Windows Explorer.  The file manager 
will then go up to the \\afs root and display the list of shares (freelance 
mountpoints) correctly.

If I try to enter '\\afs' directly into the location bar, I will usually get 
the same error as before (from the "Run" command in the start menu).

I obtained the output of 'fs trace -dump' during which time the error 
occurred.  I reproduced this as follows:

 	1. Reboot the machine

 	2. Log in with a windows domain account, but do not obtain any AFS

 	3. Run (as administrator):

 		fs trace -reset

 		fs trace -on

 	4. Go to the start menu, click "Run" and enter '\\afs'

 	5. The error is displayed (it does not browse \\afs properly)

 	6. Run (as administrator)

 		fs trace -dump

 		fs trace -off

 	7. Copy the resulting C:\WINDOWS\Temp\afsd.log file

The log file is available for downloading here:


In the log file, the following names are used:

 	ultra20, ULTRA20	- machine's host name
 	localadmin		- name of local administrator account
 				  (used to run 'fs trace' commands)
 	UMROOT\wingc		- my Windows domain account which I was
 				  logged in as (when trying to browse

Any ideas?

Thanks a lot,

Chris Wing