[OpenAFS] Building openafs.ko for latest FC5 kernel

Mike Polek mike@pictage.com
Tue, 24 Oct 2006 16:45:50 -0700

Hi, all,
   I recently installed the latest FC5 kernel on one of
my Linux boxes. There appears to be a discrepancy between
what the kernel package provides and what the 1.4.2
openafs-kernel-smp package requires.

We built the openafs kernel module rpm as follows:

# rpmbuild --rebuild --target=i686 --define "kernvers `uname -r`" 
openafs-1.4.2-fc5.1.src.rpm < /dev/null >& /tmp/openafs.buildmodules.log &

# uname -r

When attempting to install, the following error occurs:

# rpm -ivh openafs-kernel-smp-1.4.2-2.6.18_1.2200.fc5smp_1.i686.rpm --test
error: Failed dependencies:
         kernel-smp-i686 = 2.6.18-1.2200.fc5 is needed by 

The kernel rpm provides two related things: kernel-i686 and kernel-smp:

# rpm -qp kernel-smp-2.6.18-1.2200.fc5.i686.rpm --provides
warning: kernel-smp-2.6.18-1.2200.fc5.i686.rpm: Header V3 DSA signature: 
NOKEY, key ID 4f2a6fd2
kernel = 2.6.18
kernel-drm = 4.3.0
kernel-i686 = 2.6.18-1.2200.fc5smp
kernel-smp = 2.6.18-1.2200.fc5

openafs wants kernel-smp-i686:

# rpm -qp openafs-kernel-smp-1.4.2-2.6.18_1.2200.fc5smp_1.i686.rpm --requires
kernel-smp-i686 = 2.6.18-1.2200.fc5
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

Previously, openafs required kernel-smp

# rpm -q openafs-kernel-smp --requires
kernel-smp = 2.6.16-1.2122_FC5
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

Should I modify the Requires: line from

Requires: kernel-smp-%{_target_cpu} = %{kversion}


Requires: kernel-smp = %{kversion}

Or is there some other solution? Am I building the module rpm
incorrectly?  If this is a bona fide bug, where should I report it?

Thanks in advance,

Michael Polek
Director of System Operations
Pictage, Inc.
1580 Francisco Street, Ste. 101
Torrance, CA 90501
(310) 525-1600 ext. 628