[OpenAFS] Re: OpenAFS 1.4.2 on latest FC5 kernel

Axel Thimm openafs-info@openafs.org
Thu, 26 Oct 2006 15:58:41 +0200

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Thu, Oct 26, 2006 at 02:40:16PM +0100, David Howells wrote:
> Axel Thimm <Axel.Thimm@ATrpms.net> wrote:
> > There are packages for 2200 at http://atrpms.net/dist/fc5/openafs/
> I tried downloading and building your SRPM, but I get this error:
> 	altair#rpmbuild --rebuild /tmp/openafs-1.4.2-20.at.src.rpm=20
> 	Installing /tmp/openafs-1.4.2-20.at.src.rpm
> 	warning: InstallSourcePackage: Header V3 DSA signature: NOKEY, key ID 66=
> 	error: line 1: Unknown tag: %kmdl openafs

Add http://orion.lcg.ufrj.br/~roma/scripts/macros.txt to ~/.rpmmacros
or /etc/rpm/macros. Have you tried the binary packages?

> Also, shouldn't the openafs-doc package really be noarch?

Yes, but that can only be done if the package is split at source level
(that's an rpm restriction, not much you can really do about) and the
maintainer of this package prefered not to artificially decompose the
src.rpm for the sake of noarching the docs. It doesn't really hurt
other than adding 6MB to the mirror space.
Axel.Thimm at ATrpms.net

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.4.5 (GNU/Linux)