[OpenAFS] SOS: AFS instllation/Configuration

Christopher D. Clausen cclausen@acm.org
Thu, 1 Feb 2007 07:53:19 -0600

Srikanth Bhaskar <srikanth.bhaskar@gmail.com> wrote:
> Now, when I run the initialization script on AIX, /etc/rc.afs; i got
> an error that /usr is jfs2 and it needs to be jfs.

Hmm...  This shouldn't matter if you are using -memcache, perhaps you 
can comment out the jfs check, assuming its in the /etc/rc.afs file and 
not compiled in.

> Hence, we created a new partition /afs1 with jfs and now updated the
> cacheinfo to
> /afs:/afs1/vice/cache:50000
> when I run the initialization script AIX restarts. But when I revert
> back the info in "cacheinfo", it does not.
> Hence, debugging the rc.afs script, exit the script before running
> the afsd, we diecided to go for -memcache
> we ran: /usr/vice/etc/afsd -memcache -chunksize 28, the system
> restarts again.

Thats a bit large of a chunksize.
Does /usr/vice/etc/afsd -memcache -chunksize 18 -blocks 65536 work for 

> I am unable to run the script  to run the cache manager and go ahead
> with this.
> Has anyone come across this issue? Please help us resolve the issue.

I've seen the -memcache option frequently cause crashes if the cache 
size is set too high.