[OpenAFS] AFS service may not have started

Jeffrey Altman jaltman@secure-endpoints.com
Fri, 11 Jul 2008 13:17:02 -0400

Michal Rybarik wrote:
> Hello,
>>> Tokens held by the Cache Manager:
>>> pioctl CreateFile(\\afs\all\_._AFS_IOCTL_._) failed: 0x7B
>>>        [The filename, directory name, or volume label syntax is incorr
>>> ]
>>> pioctl Explorer logon user: [pichal]
>>> pioctl WNetAddConnection2(\\afs,pichal) failed: 0x52E
>>> pioctl WNetAddConnection2(\\afs\all,pichal) failed: 0x52E
>>> pioctl SamCompatible logon user: [MONEY\pichal]
>>> pioctl WNetAddConnection2(\\afs,MONEY\pichal) failed: 0x52E
>>> pioctl WNetAddConnection2(\\afs\all,MONEY\pichal) failed: 0x52E
>>> AFS device may not have started
>> Has the service started?  What are the contents of the afsd_init.log 
>> file?
>> Is "AFS" registered as a service name according to "nbtstat -n"?
>> Note that 0x52E is Logon Failure.  unknown user name or bad password.
>> How are you logging on to the workstation?  Are you using a method that
>> does not make use of a password?   Is NTLM disabled on the machine?
> Contents of afsd_init.log and "nbtstat -n" is below, I think everything 
> seems to be OK. Service is started and seems to be running normally. We 
> also tried to start/stop service, uninstall & reinstall AFS, but nothing 
> helped. We had the same issue on another XP machine few months ago, 
> after a weeks of fixing, we reinstalled the whole machine and then it 
> started work... On this machine it is the same, AFS has been working 
> well on it before, but one day it stopped suddenly and we can't find a 
> way to bring it back. There are also around 5 other WinXP clients on the 
> same network and also some clients running on Linux (server is Linux 
> also), and they are all working well. Login & password is 100% OK, we 
> tried also another accounts which works on other AFS clients, I think 
> that the problem is with this
>     pioctl CreateFile(\\afs\all\_._AFS_IOCTL_._) failed: 0x7B
> and the login problem is shown because this one was unsuccessful, but 
> maybe I'm not correct at this point.

0x7B is invalid name.  The only part of that name that might be 
considered invalid is \\afs and only if the AFS netbios name is invalid.
> Login to the workstation is local XP account, the same username & 
> password as on AFS server.
> The funny/strange thing is, that the same thing happened also few weeks 
> ago on the other WinXP - AFS client suddenly stopped to work, exactly 
> the same way. But after a week or so, it started to work again, as if 
> nothing happend! We are 100% sure that it wasn't broken by the user, 
> because only my colleague and I have access to this computer, and we 
> both are admins and we both know what we do :o)

I agree that all of this looks valid.

I think that anything further is going to require a debugger and it
would probably be easiest if I drove.  Would that be possible?