[OpenAFS] OpenAFS RPMs and new kernels

Alexander Bostr÷m abo@kth.se
Mon, 23 Jun 2008 13:09:55 +0200


Btw, I noticed the new dkms-openafs package in the repository. I think
I'll just use that instead of the kmod packages. Thanks!

/abo

ons 2008-06-11 klockan 16:24 +0200 skrev Alexander Bostr├Âm:
> Hello again!
> 
> I don't see any new packages being built for newer RHEL/CentOS 5
> kernels. The latest built kmod-openafs* RPMs works fine even with new
> kernels thanks to the weak-modules thing. Is that the reason why no new
> packages is being built?
> 
> The reason I ask is because I don't have a sane workaround to avoid the
> following scenario:
> 
>  Install EL5.
>  yum update
>  add openafs yum repo
>  yum install openafs-client kmod-openafs
> 
> The above fails because kmod-openafs requires an old kernel package
> which rpm refuses to install since it's older than an already installed
> package. (For example 2.6.18-92.1.1.el5 and 2.6.18-53.el5 is installed
> but kmod-openafs requires 2.6.18-53.1.21.el5.)
> 
> /abo
> 
> 
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info