[OpenAFS] Mac OSX Finder drag-and-drop failures

Richard Brittain Richard.Brittain@Dartmouth.EDU
Mon, 17 Mar 2008 02:40:43 -0400 (EDT)

    I recently ran into a problem with the Mac OSX Finder and AFS, which 
was frustratingly difficult to pin down to any particular configuration or 

The Finder would not allow _any_ file dragging out of AFS (circle-slash 
icon), regardless of destination.  Files could be opened by 
double-clicking, and copied with command line tools, and the Finder would 
drag files up to AFS (given appropriate tokens and ACLs).  I found this on 
three different systems, all previously working fine.  With a few reboots 
and restarts of the AFS client, I could get two of them working again, at 
least temporarily.  I tried changing the afsd options and CellServDB but 
nothing seemed to make a difference (I usually run with -afsdb and a null 
CellServDB - I only need to see my local cell).  It seemed to have no 
relation to ACLs or tokens.

MacOS OS 10.4.11
OpenAFS versions tried: 1.4.4, 1.4.5, 1.5.28

[ The reason I needed this was to copy some Mac-created files out of AFS, 
which had such pathological names that none of the command line tools (cp, 
tar, ditto) would succesfully get them all - but I can't blame AFS for 
that ]

I strongly suspect that this started happening with some relatively recent 
OSX system update, but I've got no older system images to test on.  They 
are all 10.4.latest

Anyone else seen similar behaviour ?

Richard Brittain
Richard Brittain,  Kiewit Computing Services, 6224 Baker/Berry Library
                    Dartmouth College, Hanover NH 03755
Email: richard.brittain@dartmouth.edu