[OpenAFS] AFS Perl under debian lenny - problem?

Lars Schimmer l.schimmer@cgv.tugraz.at
Tue, 27 May 2008 11:42:27 +0200

Hash: SHA1

Norbert Gruener wrote:
> Hi Lars,
> On Mon, May 05 2008, Lars Schimmer wrote:
>> Hi!
>> I used to use the afsss.pl script from mr. Wiesand
>> http://www-zeuthen.desy.de/~wiesand/AFS/ and all was fine after I got
>> the perl modules as a .deb.
>> But since a few days (after some updates) I get this error:
>> vldb->listaddrs Code=3DAFS::VLDB: could not list the server addresses
>> Is anyone else using the AFS::VLDB package or the script on debian
>> lenny/etch and can give me a hint what went wrong?
> the appended patch should solve your problem.  Please let me know if
> it is working for you.

I applied the patch, finally.

I run perl Makefile.PL and got:

perl Makefile.PL
Checking if your kit is complete...
Looks good

Path to the AFS installation (libraries, binaries,
header files) to be used for this installation?           [/usr]
AFS Version =3D OpenAFS 1.3
Your AFS system libraries are located at:  /usr
                  their major version is:  OpenAFS 1.3
                  and their type is:       "pthreaded"
Your AFS system type seems to be:          i386_linux26

Is this really OK? I thaught I run OpenAFS 1.4.7.

I build inside of OpenAFS and run the make test.
I hit:
PERL_DL_NONLAZY=3D1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, '../../blib/lib', '../../blib/arch')" t/*.t
t/BOS....ok 4/32#     Failed test (t/BOS.t at line 31)
t/BOS....ok 32/32# Looks like you failed 1 tests of 32.
        Test returned status 1 (wstat 256, 0x100)
        Failed 1/32 tests, 96.88% okay
Failed Test Stat Wstat Total Fail  Failed  List of Failed
t/BOS.t        1   256    32    1   3.12%  5
Failed 1/1 test scripts, 0.00% okay. 1/32 subtests failed, 96.88% okay.
make[2]: *** [test_dynamic] Error 2
make[2]: Leaving directory `/afs/cgv.tugraz.at/tmp/AFS-2.4.0/src/BOS'
make[1]: *** [test] Error 2
make[1]: Leaving directory `/afs/cgv.tugraz.at/tmp/AFS-2.4.0/src'
make: *** [test] Error 2

and after make install afsss.pl hit a segmentation fault.

> Cheers,
> Norbert

Lars Schimmer
- --
- -------------------------------------------------------------
TU Graz, Institut f=FCr ComputerGraphik & WissensVisualisierung
Tel: +43 316 873-5405       E-Mail: l.schimmer@cgv.tugraz.at
Fax: +43 316 873-5402       PGP-Key-ID: 0x4A9B1723
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org