[OpenAFS] /afs area is hanging

Derrick Brashear shadow@gmail.com
Wed, 13 May 2009 11:59:18 -0400

On Wed, May 13, 2009 at 11:16 AM, Mark Henry <mark.henry@infoprint.com> wro=
>> that may well be related to the problem. what cron jobs do you have?
>> Derrick
> This is a happy day. =A0Derrick it looks like your skills have pointed us=
 to the
> solution. =A0I mentioned that we use a loopback device to mount our afs c=
> filesystem. =A0That device was /dev/loop0. =A0Well, after the direction t=
hat you
> gave us we found that /dev/loop0 was also being used as a method of restr=
> font cache for a different app. =A0When the app would run the afs cache w=
> getting clobbered and the afs hang would follow. =A0We have moved the afs=
> to a new place now and it looks like this problem has been solved. =A0Tha=
nk you
> all on openafs.org that helped us with this issue. =A0Thank you Derrick f=
or the
> key piece of info that has solved this one.

If you wipe out your cache, AFS does tend to perform badly. I
recommend against it ;)

That said, we can (and possibly also will) improve the behavior a bit.