[OpenAFS] Linux packages for 1.5?

Dale Pontius pontius@btv.ibm.com
Wed, 07 Apr 2010 14:40:21 -0400

On 04/07/10 14:28, Russ Allbery wrote:
> Dale Pontius <pontius@btv.ibm.com> writes:
>> At what point should the 1.5.xx series be considered "usable" on Linux?
>> I'm thinking usable as 1.4.xx is, not trying disconnected mode, at the
>> moment.
> I finally got a working build on Debian with plus two additional
> patches (one of which has been merged and one of which is still in
> review), so that's a good sign.  :)  I agree with your general impression
> that up until now we've not really been there on Linux, but we seem to be
> stabilizing.
> I would give it a while longer, though, before considering it as stable as
> 1.4.x.  At least a couple more releases, I suspect.
>> I've tried Linux clients from 1.5.71-73 with varying amounts of success,
>> but in no case has it been sufficient.  A quick look at my domain, and
>> you'll see that I'm likely connecting to a stunning (or annoying)
>> variety of servers, which might explain my results.  In every case, I've
>> had "holes" in my data as viewed in /afs.  Though those holes have
>> gotten smaller with each release, some still appear to be there with
>> 1.5.73.  Is there something I can run that will furnish debug
>> information to be of some help?
> The first thing I would try, based on my experience from yesterday, is to
> stop your AFS client and completely purge your cache directory.  Then
> start it again and see if the holes have gone away.
A year or two back I was having some odd cache issues with the stable
client.  I hacked the init script (This is Gentoo, by the way.) to clear
the cache each time right before starting the client.  That solved my
problems back then, and at some point the init script got overwritten by
an update.  But by then my cache problems were gone, so I didn't worry
about it.  It's certainly easy to put back in.
> When switching from 1.4 to 1.5, I got some weird cache artifacts.  I
> thought that was because I also had a kernel panic with the new version
> that could have left the cache in an inconsistent state, but I'm wondering
> if there may be some more basic upgrade problem.
> Other people have been switching back and forth without encountering this
> problem, so this may be a red herring, but it's worth a try.
I'll certainly try clearing the cache.  But I'm also guessing that I'm
also talking to a greater-than-average variety of servers, and wondering
if there could be a vintage problem here.  Is there a way to query a
mount point to find the server version providing that data?  (Or perhaps
there's other relevant information to query.)


Dale Pontius
Senior Engineer
IBM Corporation
Phone: (802) 769-6850
Tie-Line: 446-6850
email: pontius@us.ibm.com

This e-mail and its attachments, if any, may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply e-mail and delete all copies of this message from your system without copying it and notify sender of the misdirection by reply e-mail.