[OpenAFS] Windows 7 Sleep behavior-Broken AFS Lock on wakeup

Wayne Greene wayne_greene@unc.edu
Tue, 13 Apr 2010 15:21:29 -0400


We are using Windows 7 Enterprise, MIT Kerberos for Windows 3.22, and 
Open AFS 1-5.6.800 and have encountered a problem for our laptop users 
and the sleep function. When the computers wake, the AFS lock symbol in 
the system tray shows that it is broken and cannot connect to the AFS 
service. Net ID manager shows they have AFS tokens and kerberos tickets 
but AFS shares cannot be accessed until the computer is restarted. I 
have tried destroying the Network ID credentials, stopping the AFS 
service then sleeping the computer, regaining credentials and restarting 
the service and after waking up it still doesn't work. I found a power 
management option in the Lenovo Power Manager that will keep the network 
connection for a specific amount of time during sleep, but that has not 
worked either. These so far are Lenovo computers, my test machine is a 
ThinkPad R400 but the symptom is the same on a few different models. Is 
anyone else experiencing this and/or has anyone found a fix if so? Thanks.

Wayne Greene
Computer Science
UNC Chapel Hill