[OpenAFS] afsmonitor segfault

lists@drewstud.com lists@drewstud.com
Mon, 23 Aug 2010 13:01:20 -0400 (EDT)

All machines I have tried are 64bit, but I found an i386 one and it worked =
fine. =0AKnowing it works on 64bit 1.5 and not 1.4.12 is good too. =0AThank=
s as always. =0A=0A=0A=0A-----Original Message-----=0AFrom: "Stephan Wiesan=
d" <stephan.wiesand@desy.de>=0ASent: Monday, August 23, 2010 12:17=0ATo: op=
enafs-info@openafs.org=0ASubject: Re: [OpenAFS] afsmonitor segfault=0A=0A=
=0AOn Aug 23, 2010, at 18:06 , Derrick Brashear wrote:=0A=0A> On Mon, Aug 2=
3, 2010 at 11:58 AM,  <lists@drewstud.com> wrote:=0A>> I am using openafs 1=
.4.11 .=0A> =0A> That's not the greatest of ideas, but I doubt it's the pro=
blem.=0A> =0A>> I want to gather statistics and if I do not specify the -ou=
tput flag, afsmonitor works fine. However when I call:=0A>> afsmonitor -fsh=
osts <fqdn> -output stats.txt=0A>> It segfaults=0A>> http://pastebin.com/MD=
pUW7ww=0A>> =0A>> Am I calling it with the wrong?=0A> =0A> I don't have any=
thing as old as 1.4.11, and I'm not going to install=0A> it. However I'd ve=
nture it's either=0A> 1) a bug we fixed, probably in the 1.5 series in git =
commit=0A> 2) a bug we didn't fix which only occurs when (a server is down,=
 some=0A> similar situation)=0A> 3) do you perchance have 64 bit machines a=
t one or both ends, and=0A> perhaps we have some non-64-bit-safe handling i=
n the code?=0A> =0A> (It works in the basic test case I fired off using you=
r command; I'll=0A> try to poke later, but still not with 1.4.11, which is =
obsolete)=0A=0AThis problem is present in 1.4.12 on amd64 - i386 works (SL5=
 clients, server is SL5 amd64). With 1.5.76, amd64 is ok as well.=0A=0A-- =
=0AStephan Wiesand=0ADESY -DV-=0APlatanenenallee 6=0A15738 Zeuthen, Germany=
=0A=0A_______________________________________________=0AOpenAFS-info mailin=
g list=0AOpenAFS-info@openafs.org=0Ahttps://lists.openafs.org/mailman/listi=