[OpenAFS] Building SRPM on RHEL6 Beta 2

Michael Waltz mwaltz@qualcomm.com
Fri, 27 Aug 2010 14:41:25 -0700

This is a multi-part message in MIME format.
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Has anyone else tried to build the openafs-1.4.12-1.1.2.src.rpm on the 
latest RHEL6 Beta 2?

It appears that in RHEL6 uname -r has changed behavior (see link below) 
and kernvers will double up the architecture while building, resulting 
in a .x86_64.x86_64 naming scheme. I've tried to work around the problem 
by doing a --define "kernvers `uname -r | sed s:.x86_64::`" but it still 
errors out. Also, in RHEL6 the file /usr/kerberos/bin/krb5-config is now 
located in /usr/bin/krb5-config, which I've attached a patch for the 
.spec file..

I'm going to attempt to work around the uname -r issue by changing it in 
some of the build scripts, and I'll send out some patches if I get it 
working correctly. If anyone else has run into this and has a workaround 
for building from the src.rpm on RHEL6 though I'd appreciate it.

Build cmdline:
rpmbuild -bb -vv /root/rpmbuild/SPECS/openafs.spec --define "kernvers 
`uname -r | sed s:.x86_64::`"

uname -r:

Error is:
Processing files: kmod-openafs-1.4.12-
error: File not found: 

RPM build errors:
     File not found: 

Redhat Bug that changed behavior or uname -r in RHEL6:

Thank you,

Micheal Waltz
Qualcomm Inc.
Phone: 858-845-6083
Cell: 858-882-7079

Content-Type: text/x-patch;
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;

--- /root/rpmbuild/SPECS/openafs.spec	2010-08-27 14:01:47.508127439 -0700
+++ /local/mnt/openafs/openafs.spec	2010-06-01 05:47:21.000000000 -0700
@@ -105,7 +105,6 @@
 %if %{krb5support}
 %if %{?krb5config:0}%{!?krb5config:1}
 %define krb5config /usr/kerberos/bin/krb5-config
-%define krb5config /usr/bin/krb5-config