[OpenAFS] Install OpenAFS on ppc64?

Ting-jen Yen yentj@infowrap.com.tw
Mon, 22 Aug 2011 12:49:51 +0800


  Has anyone successfully installed OpenAFS on RHEL5 machines with
ppc64 arch? (Power6 CPU, virtualized by PowerVM).
  I was using SRPMs from the OpenAFS site.  Rpmbuild showed some
errors, and I have to specify to build userspace, modules, and
authlibs packages, then modify the source, 'flock64' to 'flock' in
src/afs/afs.h.  This way, I could build the RPMs, and install
them.  However, even though the installation succeeded, I cannot start
the client service.

  If I added options '-debug' and '-verbose' to afsd, it will show

afsd: enabling dynamically allocated vcaches
afsd: My home cell is 'mycell'
ParseCacheInfoFile: Opening cache info file '/usr/vice/etc/cacheinfo'...
ParseCacheInfoFile: Cache info file successfully parsed:
        cacheMountDir: '/afs'
        cacheBaseDir: '/usr/vice/cache' 
        cacheBlocks: 100000
afsd: cacheFiles autotuned to 3125 
afsd: dCacheSize autotuned to 2000
afsd: cacheStatEntries autotuned to 3000
SScall(137, 28, 35)=-1 SScall(137, 28, 17)=-1 afsd: Forking rx listener
SScall(137, 28, 48)=-1 afsd: Forking rx callback listener.
SScall(137, 28, 0)=-1 afsd: Forking rxevent daemon.
SScall(137, 28, 19)=-1 SScall(137, 28, 36)=-1 afsd: Error -1 in basic

  Anybody could help me with this?  I tried 1.4.7, 1.4.14, 1.5.78, and
1.6.0-pre1, and all with the same result.  Other machines with x86_64
work fine.

Ting-jen Yen, Assistant Manager
R&D Dep.
No.2060, Yucheng Rd., Gushan District,
Kaohsiung City 80458, Taiwan
Tel: 886-7-5228611 Ext.22
Fax: 886-7-5228986
E-mail: yentj@infowrap.com.tw