[OpenAFS] problems with de-installing OpenAFS 1.5.x on windows 7

Lars Schimmer l.schimmer@cgv.tugraz.at
Fri, 23 Sep 2011 09:00:34 +0200


I experienced some heavy problems with deinstalling the 64bit package of=20
OpenAFS 1.5.x on our windows 7 workstations.

While/after deinstalling the 64bit package (MSI) of OpenAFS 3 (out of 6=20
I tried) workstations did no more accept any admin user as=20
administrator, the service to start the services did not start and=20
furtheron I can onl reinstall complete system to get it working again as=20
I do not obtain any right to administrate the system or start any=20
servive =3D> I cannot deinstall/install any software, I cannot remove it=20
from the domain, I can just logon/logoff and copy data to/from harddrive).

Has anyone experienced and similar?

(the workstations were setup in last/this year, are in a domain,=20
upgrading OpenAFS did worked well on them, I was login  as a local=20
administrator while deinstalling the OpenAFS 64 MSI package,...).

Somehow it looks like the registry is destroyed in a very bad manner.
And this has happen on 3 workstations yet (out of 6 I tried to deinstall=20
OpenAFS 1.5.x for installing 1.7).

Lars Schimmer
TU Graz, Institut f=FCr ComputerGraphik & WissensVisualisierung
Tel: +43 316 873-5405       E-Mail: l.schimmer@cgv.tugraz.at
Fax: +43 316 873-5402       PGP-Key-ID: 0x4A9B1723