[OpenAFS] Naming of "backup" and "up" commands
Sun, 22 Sep 2013 17:51:40 -0700
In the Debian packaging for OpenAFS, I've renamed the "up" command to
"afs-up" for years now. There's now also a conflict with the "backup"
command (which is a horrible name for a command), and I'm rather tempted
to do the same thing, but since it's a whole command suite with multiple
documentation pages and cross-references, it's more of an undertaking.
What would people think if I submitted a patch to OpenAFS to rename up to
afs-up and backup to afs-backup? Would that break a bunch of critical
software? It would be really nice to fix AFS's camping on obvious
Failing that, I'm probably going to split butc, backup, and fms into a
separate package to make it easier for other packages to conflict with it
due to the poorly-chosen command name instead of conflicting with all of
Russ Allbery (email@example.com) <http://www.eyrie.org/~eagle/>