[OpenAFS] Compiling and 1.6.6 end in compilation failure for OpenAFS.prefPane

Benjamin Kaduk kaduk@MIT.EDU
Mon, 24 Mar 2014 11:17:23 -0400 (EDT)

Hi Frederick,

On Mon, 24 Mar 2014, Frederick Luehring wrote:

> Hi Everyone,
>   I am running Mac Mavericks version 10.9.2. Over the December holiday break,
> I was able to build and install OpenAFS so AFS was working on
> Mavericks. Since then I installed 1.6.6 from the
> http://www.openafs.org/dl/openafs/1.6.6/macos-10.9/OpenAFS-1.6.6-Mavericks.dmg
> file that you supply. This version seemed install and work but the control
> panel still showed version I uninstalled the dmg version using the
> uninstall script which generated a huge number of errors about bill of
> material entries. This did seem to uninstall OpenAFS (or at least /afs was
> empty after a reboot). I then tried to manually build both and 1.6.6
> and get the failure you see at the end of the output message fragment you see
> below signature. I tried upgrading the March 10 version Apple Xcode command
> line tools but that did not help. For the record the commands I executed were:

The March 10 version of Xcode (5.1) is going to be actively harmful; I 
believe it will not compile the prefpane from any released version at 

> Any suggestions would be appreciated. I am far from an expert so I could be
> doing something simple wrong.
> Fred
> (Release) ===
> error: garbage collection is no longer supported

In particular, this error appears to be new with Xcode 5.1. 
http://gerrit.openafs.org/#change,10925 is the patch that should resolve 
this particular build issue.

I trimmed some other error messages from the quoted text; I don't have any 
idea what would be causing them, sorry.

-Ben Kaduk