[OpenAFS] ls: : Operation timed out

Yannick Ulrich yannick.ulrich@psi.ch
Mon, 24 Apr 2017 10:01:01 +0200

Dear all,

since a couple of days, I=E2=80=99m having trouble accessing my AFS home
directory from my computer (macOS 10.12.4)

    $ ls /afs/psi.ch/user/u/ulrich_y/
    ls: : Operation timed out

=46rom other machines, this is no problem and I can check on which host
this directory is

    $ ls /afs/psi.ch/user/u/ulrich_y/
    # Lists directory content
    $ fs whereis /afs/psi.ch/user/u/ulrich_y/
    File /afs/psi.ch/user/u/ulrich_y/ is on host afsfs11.psi.ch

However, I can access other directories and files that are hosted on
other servers

    $ fs whereis /afs/psi.ch/<some other file>
    File /afs/psi.ch/<some other file> is on hosts afsfs00.psi.ch=20
        afsfs02.psi.ch afsfs05.psi.ch

To further investigate this, I ran fs checkservers on my computer

    $ fs checkservers
    These servers unavailable due to network or server problems: =20

=46rom other machines this works fine so it appears to be somewhat
localised to my computer.

I've tried flushing which doesn't help

    $ fs flushall
    $ fs checkv
    All volumeID/name mappings checked
    $ ls /afs/psi.ch/user/u/ulrich_y/
    ls: : Operation timed out

I've rebooted my computer and reinstalled the client to no avail.

Installing the client on a virtual machine on my computer works out of
the box.

Some further details:

* I'm using macOS 10.12.4

* The client I'm using is with openafs

* I'm using is a third-party binary from Sine Nomine Associates (c.f.

* The server in question uses OpenAFS built  2017-01-06

    $ /Library/OpenAFS/Tools/etc/rxdebug afsfs11.psi.ch -version
    Trying (port 7000):
    AFS version:  OpenAFS built  2017-01-06

I'd appreciate any suggestion!


Yannick Ulrich
Laboratory for Elementary Particle Physics
Paul Scherrer Institut
WHGA 127
CH-5232 Villigen PSI
Tel: +41 56 310 3663
Email: yannick.ulrich@psi.ch