[OpenAFS] KeyFile issues upgrading servers from 1.4 to 1.6

Anjana Kar kar@psc.edu
Wed, 20 Dec 2017 14:27:36 -0500

Currently we have 4 servers running openafs-server-1.4.14-el5.1.1,
2 of them being database servers.
The new VM servers have openafs-server-1.6.16-1.el7.centos.x86_64,
and we'd like to configure them so they can replace the 1.4 servers.

The first problem we've run into is with the KeyFile. "bos create" also
gives the same message.

[root@afs-vma etc]# bos listkeys afs-vma.psc.edu -localauth
bos: ticket contained unknown key version number error encountered while 
listing keys

Question is do we need to create a new KeyFile?

Are there any documentation or steps we can follow for this migration?

-Anjana Kar
  Pittsburgh Supercomputing Center