[OpenAFS] AFS hangs on cache initialization at startup

Derek Atkins warlord@MIT.EDU
20 Apr 2001 16:06:28 -0400

Have you tried the -debug option to afsd so that you might get an idea
where it is in the process when it hangs?  How big is your AFS Cache?
What kind of filesystem is it sitting on?


Michael Durket <durket@100acrewood.stanford.edu> writes:

> On s390 Linux kernel 2.2.19 (latest RedHat beta), I've recompiled
> OpenAFS 1.0.3 (using the s390 patches). Mostly, AFS fails to start
> properly - it hangs in the AFS cache scan. On very rare occasions
> it will start.
> I've tried debugging this by putting printf statements in various
> places, but this just moves the problem apparently. Sometimes
> AFS will come up ok, sometimes it hangs in a different place. But,
> it's always hung doing the AFSOP_CACHEINIT call.
> I'm not saying that this is an AFS problem (it might be the beta
> kernel), but I'm looking for some suggestions from more experienced
> AFS debuggers who might have seen similar hangs in cache init on
> Linux or other OSes and have suggestions about how to approach
> debugging the problem.
> Thanks,
> Mike Durket
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo.cgi/openafs-info

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord@MIT.EDU                        PGP key available