[OpenAFS] Unable to authenticate to AFS because no such entry

Jeffrey Hutzelman jhutz@cmu.edu
Fri, 29 Jun 2001 15:56:28 -0400 (EDT)

On Tue, 26 Jun 2001, Pieter-Paul Giesberts (ELN) wrote:

> Hmm did what you recommended, do I shutdown afs, deleted all database
> files and rebooted. All users were gone. I created 1 user again in kas,
> bos and pts (like in the manual). I made sure this was the only user and
> that all settings were rcorrect. If I try to 'klog' I once again get the
> same error. Perhaps it's not an authentication problem, because I found
> this similar problem as well: 

> If I run 'vos listvol <server>' I get a number of volumes I created
> (with the localauth switch), amongst which are root.afs and root.cell.
> All these volumes are empty as I have never been able to enter the /afs
> directory. However, if I run 'vol listvldb <server>' it says: 'VLDB: no
> such entry'!

This is because the first argument to 'vos listvldb' is a volume name, not
a server name.  Try 'vos listvldb -server <server>'.

> My VLLog file looks normal: 2 entries, 1 says which IP address is used
> as primary address, the other says 'starting AFS vlserver 4' My
> VolserLog looks normal as well. 

Looking at the error tables, only two modules have errors whose associated
text is 'no such entry'.  The first is the vlserver, which returns
VL_NOENT (No such entry) when you try to look up, modify, or delete a
nonexistent VLDB entry.  This is the error you were seeing about from 'vos

The second is the KTC (kernel token cache, part of the cache manager),
which returns KTC_NOENT (no such entry) in the following cases:

- ktc_GetToken, when there is no AFS token for the specified cell
- ktc_ListTokens, when there are no relevant tokens
- ktc_SetToken, when there is no space for the specified token.

These are errors coming from your AFS libraries or cache manager, NOT from
the server.  Also, note that the KTC error is 'no such entry', while the
VLDB error is 'No such entry'.

-- Jeffrey T. Hutzelman (N3NHS) <jhutz+@cmu.edu>
   Sr. Research Systems Programmer
   School of Computer Science - Research Computing Facility
   Carnegie Mellon University - Pittsburgh, PA