[OpenAFS] Lost files

Brian Beezhold homie@mac.com
Mon, 17 Sep 2001 13:10:42 -0400

Yep, I've experienced the exact same thing. I have a similar setup
and it only seems to be my home directory that ever gets affected.
None of the other users on the system have ever had this happen. I
thought it might have something to do with my workstation running with
an XFS filesystem but if your having the same problem I guess not.

On Mon, Sep 17, 2001 at 02:28:02PM +0200, Pär Aronsson wrote:
> Hello everyone.
> I have some really bad trouble with OpenAFS. A number of times I have 
> lost all files in my home directory.
> What happens is that all of the files are suddenly missing when I log 
> in. When I do a "fs lq ." in my home directory it reports what seams to 
> be a correct amount of data, but "ls -las" show me nothing. I have done 
> salvage without result. I have tried accessing the volume using my own 
> kerberos ticket, admin ticket and no ticket.
> I have tried mounting the .backup volume and the rw volume in different 
> places and I've tried with the volume in the dump. So it seams something 
> happens before the dump is made. Please note we use "vos dump" to a file 
> rather than "backup dump" to tape.
> I have experimented with different versions of AFS (both OpenAFS and 
> Transarc AFS) on the client, the server has been upgraded when new 
> OpenAFS releases has been made available. This problem has happend every 
> two months or so since OpenAFS 1.0 was released. Since then the OS has 
> been upgraded as well.
> I'm the only one in the office with this problem, so it seams either I'm 
> doing something bad or my harware does.
> Has enyone else experienced this and is there a solution?
> Pär Aronsson