[OpenAFS] fileserver problem on 1.2.11 and SuSE 9.0

Derrick J Brashear shadow@dementia.org
Fri, 18 Jun 2004 16:58:09 -0400 (EDT)

On Fri, 18 Jun 2004, Lewis, Dave wrote:

> > Before, you could setenv LD_ASSUME_KERNEL 2.4.1 and use the tviced
> > (pthreads) fileserver and all would be well. I bet that isn't true
> > anymore.
> We tried this. You're correct -- it doesn't work.

The Magic 1000 ball told me as much;-) (*)

> > If you feel like debugging the pthreads implementation you have and
> > figuring out how it's different from every other
> > implementation, well, I
> > suspect you don't, but that's what's needed.
> You're correct again (sorry!).

I don't blame you. Debugging pthreads is a bitch. I wrote an LWP wrapper
around pthreads like 5 years ago and contributed it to Arla sometime after
that. It worked with every pthreads I could find until the one in glibc
2.1 (I think) broke it... but only in a fileserver. Things like vos worked
fine. I never found the answer. I did eventually find someone with the
same problem, and they didn't get an answer either.

> However, we did try one more thing which didn't work either:
> In SuSE 9.0 there are 2 pthreads libraries, one in /lib and one
> in /lib/i686. The tviced fileserver uses the one in /lib/i686.
> We tried the one in /lib (via LD_LIBRARY_PATH) and we ran into
> the same problems.

The former is just optimized for newer processors.

> To summarize, the OpenAFS 1.2.11 server doesn't run well on SuSE 9.0
> because of the implementation of the pthreads library on that distro.
> It would be great to have a fix if possible.

It's not just SuSE 9.0. It will get worse before it gets better.

> We'll switch to SuSE 8.2, which should be fine. Thanks for your help.

* - http://members.verizon.net/~pgrzelak/1000/