[OpenAFS] Re: FreeBSD port crashes

Karsten Thygesen karthy@netic.dk
Thu, 27 Nov 2008 20:10:40 +0100


I just wish to add some more details.. I have now tried to build 1.4.8 
from source and it gave me the exact same result :-( Well - as I said, 
I'm eager, so I tried the lastest 1.5 and it builded without problems, 
but as soon as I try to load afsd (the kernel module loads fine), it 
scans the empty cache diretory and the crashes, bringing the OS to a 

Please advise how I can debug this further and how I can help providing 
more information - if anyone wish to experiemt, I might even be able to 
supply access to a server.

I should add, that the FreeBSD-7.0 server is running inside VMWare VI3, 
but I do not believe, that this have any impact.

Here is the dmesg from the latest crash:

Starting AFS cache scan...found 0 non-empty cache files (0%).
panic: mount: lost mount
cpuid = 0
Uptime: 49m56s
Physical memory: 499 MB
Dumping 98 MB: 83 67 51 35 19 3
Dump complete
Automatic reboot in 15 seconds - press a key on the console to abort

Best regards,

On 2008-11-27 12:25:45 +0100, Karsten Thygesen <karthy@netic.dk> said:

> Hi
> It was with extreme great pleasure, that I read that you know support  
> FreeBSD-7 in OpenAFS - I have awaited the port for years...
> So - now I'm eager to deploy openafs in our mixed environment, where  
> FreeBSD is quite a big part.
> I have setup Heimdal kerberos and I have installed the binary openafs  
> 1.4.8 port to FreeBSD-7.
> The sever part from this package seems to work nicely, but when I try  
> to launch afsd, it startes to scan the cachedir and finds 0 non-empty  
> files and then I get an error saying "/afs: Lost mount" and the system  
> panics.
> Do anyone have any experince with this combo? Should I go for the  
> source release instead and compile by hand?
> Karsten