[OpenAFS] Development status of mod_waklog and filedrawers

Derrick Brashear shadow@gmail.com
Wed, 20 Feb 2013 07:45:09 -0500

You can try the trivial thing: link your mod_waklog to the static
libafsauthent and libafsrpc instead of the .so versions. the issue is
probably that libafsauthent needs rx_connDeadTime from libafsrpc, tho
that should already work.

On Tue, Feb 12, 2013 at 9:39 AM, Joseph Timothy Foley <foley@ru.is> wrote:
> I followed these directions on my Ubuntu 12.04.1 32-bit machine and I sti=
ll get an odd error when I try to load the freshly built waklog module:
> apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax er=
ror on line 1 of /etc/apache2/mods-enabled/waklog.load: Cannot load /usr/li=
b/apache2/modules/mod_waklog.so into server: /usr/lib/libafsauthent.so.1: u=
ndefined symbol: rx_connDeadTime
> Action 'configtest' failed.
> The Apache error log may have more information.
>    ...fail!
> Searching through the include files in /usr/include/afs did not turn up w=
hat this symbol might referring to.  What is more puzzling is that I can't =
find a reference to this symbol in the waklog sourcecode in the first place=
> Ideas?
> I've collected the various emails/weblinks on this subject so far and put=
 up a wiki page for them:
> https://samvinna.ru.is/projects/projects/devnet-documentation/wiki/Mod_wa=
> Joe
> -----Original Message-----
> From: Staffan H=E4m=E4l=E4 [mailto:sh@ltu.se]
> Sent: 4. febr=FAar 2013 14:41
> To: Joseph Timothy Foley
> Cc: openafs-info@openafs.org
> Subject: Re: [OpenAFS] Development status of mod_waklog and filedrawers
> I got mod_waklog to work on apache 2.2 at least.
> I've found a lot of info in this posting:
> https://lists.openafs.org/pipermail/openafs-info/2009-May/031480.html
> Stephen Quinney's patches are available here:
> http://old.nabble.com/mod_waklog-tt33632100.html
> Aaron Knister's patches here:
> http://userpages.umbc.edu/~aaronk/waklog/patches_for_git
> I downloaded mod_waklog from git, and applied the patches in this order:
> patch -p1 < ../patches_aaron_knister/fix_build_scripts.patch
> patch -p1 < ../patches_aaron_knister/have_stropts_h.patch
> patch -p1 < ../patches_aaron_knister/gnu_source.patch
> patch -p1 < ../patches_stephen_quinney/modwaklog-weakcrypto.patch
> patch -p1 < ../patches_stephen_quinney/modwaklog-libs.patch
> As I said, mod_waklog seems to work perfectly. However, I haven't got fil=
edrawers to work yet. It does not seem to work with PHP 5.4.11 and Smarty 3=
> I've read that it should work with PHP 5.x, but apparently not with 5.4, =
though I think I managed to fix that. (by loading some module statically in=
stead of using "dl" - dynamically loaded modules, which is deprecated in 5.=
> Smarty 3.1.13 seems to be more difficult, I just get strange error messag=
> I've found a note somewhere that it does not work with Smarty 2.x, and th=
at version 1.x works. Maybe version 3.x has the same problem, and we need t=
o downgrade to version 1.x.
> --S
> On 2013-02-04 14:01, Joseph Timothy Foley wrote:
>> I would like to know more about this as well.  I tried to get mod_waklog=
 working on an Ubuntu 12.04 32-bit system but was unsuccessful.  It compile=
d but did not get loaded correctly into the Apache 2 I was using.  I asked =
a friend to was trying to use it at MIT, but they gave up and used IP-based=
>> Where did you find a guide indicating which patches?
>> Thanks,
>> Joe
>> -----Original Message-----
>> From: openafs-info-admin@openafs.org
>> [mailto:openafs-info-admin@openafs.org] On Behalf Of Staffan H=E4m=E4l=
>> Sent: 30. jan=FAar 2013 20:35
>> To: openafs-info@openafs.org
>> Subject: [OpenAFS] Development status of mod_waklog and filedrawers
>> What is the current status of the mod_waklog and filedrawers projects? I=
 saw a thread about mod_waklog a few months ago, but what about filedrawers=
>> I've managed to compile mod_waklog on Redhat RHEL6 64-bit after applying=
 five patches (by Aaron Knister and Stephen Quinney). It now works on Apach=
e 2.2 (haven't tried 2.4 yet).
>> Filedrawers seems to need some tweaking as well. I've found a few things=
 that needs to be changed for it to work with PHP 5.4. It also seems to hav=
e problems with the current version of Smarty (version 3.1.13). I'm working=
 through the things that need to be changed at the moment.
>> It seems both mod_waklog and filedrawers haven't been updated for severa=
l years. Does anyone maintain them?
>> /Staffan
>> --
>> Staffan H=E4m=E4l=E4
>> Lule=E5 University of Technology
>> Sweden
>> _______________________________________________
>> OpenAFS-info mailing list
>> OpenAFS-info@openafs.org
>> https://lists.openafs.org/mailman/listinfo/openafs-info
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info