[OpenAFS] Stuck in Quick start guide at "fs: You don't have the required access rights on '/afs'"

Chas Williams 3chas3@gmail.com
Mon, 14 Mar 2016 09:24:20 -0400

On Sun, 2016-03-13 at 23:15 +0100, Karl-Philipp Richter wrote:
> Am 12.03.2016 um 17:03 schrieb Chas Williams:
> > You need to authenticate via aklog (or whatever you might using)
> > or restart the servers w/o authentication so that you can add 
> > yourself to the necessary groups.  Then you can read the volumes.
> I'm authenticating with `kinit admin@[host]` as suggested in the
> QuickStart Guide, then I run `aklog` and see that I have a ticket in
> `tokens`.

Then you should have permission to read root.cell.  Did you add admin
to the system:administrators group?  Do the pts commands work?

While poking around I found this gentoo document which seems to
cover what you want:


Search for :mount

> I also tried adding `-noauth` to all programs started by the
> `openafs-fileserver` `systemd` unit in `/etc/openafs/BosConfig`
> (`-localauth` isn't available because the Ubuntu 15.10 version is a bit
> outdated and building from source fails with
> `/mnt/main/sources/openafs/src/libafs/MODLOAD-4.4.0-9-generic-MP/osi_groups.c:492:17:
> error: ‘union key_payload’ has no member named ‘value’` during
> `./regen.sh && ./configure && make`).
> What could I use as alternative to `aklog` to try it out?

Usually you create the /usr/local/NoAuth file instead of using the above.