OpenAFS Master Repository branch, master, updated. openafs-devel-1_9_2-550-ga59fd6f

Gerrit Code Review gerrit@openafs.org
Thu, 6 Aug 2026 10:55:36 -0400


The following commit has been merged in the master branch:
commit a59fd6f9fb20fb876c0a4f1aa4b60cd585d862f2
Author: Marcio Barbosa <mbarbosa@sinenomine.net>
Date:   Fri Jul 31 17:48:51 2026 +0000

    fs: Rename enum rtype to aclu_rights_type
    
    Rename the enum describing ACL rights modifiers from 'rtype' to
    'aclu_rights_type' to better reflect its purpose.
    
    Also rename the enum values as follows:
    
        add -> ACLU_RTYPE_SET
        destroy -> ACLU_RTYPE_DESTROY
        deny -> ACLU_RTYPE_DENY
        reladd -> ACLU_RTYPE_RELADD
        reldel -> ACLU_RTYPE_RELDEL
    
    Rename 'add' to 'ACLU_RTYPE_SET' because it represents setting the
    specified rights rather than adding them to the existing ACL. Also add
    comments describing the purpose of each enum value.
    
    The 'ACLU_' prefix is introduced in preparation for upcoming commits
    that will move the user-facing ACL logic from fs.c to libacl. The 'U'
    (user/utility) distinguishes it from the other ACL logic that resides
    in the library.
    
    Change-Id: Iebd0f89b0bfda572ca5654901f71514afe9f38d8
    Co-authored-by: Andrew Deason <adeason@sinenomine.net>
    Reviewed-on: https://gerrit.openafs.org/16900
    Reviewed-by: Michael Meffie <mmeffie@sinenomine.net>
    Tested-by: BuildBot <buildbot@rampaginggeek.com>
    Reviewed-by: Cheyenne Wills <cwills@sinenomine.net>
    Reviewed-by: Andrew Deason <adeason@sinenomine.net>

 src/venus/fs.c | 45 +++++++++++++++++++++++++--------------------
 1 file changed, 25 insertions(+), 20 deletions(-)

-- 
OpenAFS Master Repository